# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\+?44)?(\(\d+\))?[\d ]+(#\d+)?"
test_str = ("+447222555555\n"
"+44 7222 555 555 \n"
"(0722) 5555555 #2222\n"
"01222 555 555 \n"
"(010) 55555555 #2222\n"
"0122 555 5555#222\n"
"+44(0)7518 123 456\n"
"+44(0)7518123456")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.