#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "knop."
Local $sString = "Vind vid marken " & @CRLF & _
"Område 1c: S/15-20 knop, byar upp till 30 knop, efterhand S/15-20 " & @CRLF & _
"knop, byar upp till 35 knop. " & @CRLF & _
"Område 1a: S/10-20 knop, efterhand SO/15-20 knop, byar upp till 30 " & @CRLF & _
"knop. " & @CRLF & _
"Område 2c,3d: SO/10-15 knop. " & @CRLF & _
"Område 1b: S/15-20 knop, byar upp till 30 knop, efterhand SO/15-20 " & @CRLF & _
"knop, byar upp till 30 knop. " & @CRLF & _
"Område 2a,2b,3a,3b,3c: SO/5-10 knop, efterhand SO/10-15 knop. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")