const regex = /knop./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('knop.', 'g')
const str = `Vind vid marken
Område 1c: S/15-20 knop, byar upp till 30 knop, efterhand S/15-20
knop, byar upp till 35 knop.
Område 1a: S/10-20 knop, efterhand SO/15-20 knop, byar upp till 30
knop.
Område 2c,3d: SO/10-15 knop.
Område 1b: S/15-20 knop, byar upp till 30 knop, efterhand SO/15-20
knop, byar upp till 30 knop.
Område 2a,2b,3a,3b,3c: SO/5-10 knop, efterhand SO/10-15 knop. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}