re = /knop./
str = 'Vind vid marken
Område 1c: S/15-20 knop, byar upp till 30 knop, efterhand S/15-20
knop, byar upp till 35 knop.
Område 1a: S/10-20 knop, efterhand SO/15-20 knop, byar upp till 30
knop.
Område 2c,3d: SO/10-15 knop.
Område 1b: S/15-20 knop, byar upp till 30 knop, efterhand SO/15-20
knop, byar upp till 30 knop.
Område 2a,2b,3a,3b,3c: SO/5-10 knop, efterhand SO/10-15 knop. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end