package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`knop.`)
var str = `Vind vid marken
Område 1c: S/15-20 knop, byar upp till 30 knop, efterhand S/15-20
knop, byar upp till 35 knop.
Område 1a: S/10-20 knop, efterhand SO/15-20 knop, byar upp till 30
knop.
Område 2c,3d: SO/10-15 knop.
Område 1b: S/15-20 knop, byar upp till 30 knop, efterhand SO/15-20
knop, byar upp till 30 knop.
Område 2a,2b,3a,3b,3c: SO/5-10 knop, efterhand SO/10-15 knop. `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}