# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"knop."
test_str = ("Vind vid marken \n"
"Område 1c: S/15-20 knop, byar upp till 30 knop, efterhand S/15-20 \n"
"knop, byar upp till 35 knop. \n"
"Område 1a: S/10-20 knop, efterhand SO/15-20 knop, byar upp till 30 \n"
"knop. \n"
"Område 2c,3d: SO/10-15 knop. \n"
"Område 1b: S/15-20 knop, byar upp till 30 knop, efterhand SO/15-20 \n"
"knop, byar upp till 30 knop. \n"
"Område 2a,2b,3a,3b,3c: SO/5-10 knop, efterhand SO/10-15 knop. ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.