import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "knop.";
final String string = "Vind vid marken \n"
+ "Område 1c: S/15-20 knop, byar upp till 30 knop, efterhand S/15-20 \n"
+ "knop, byar upp till 35 knop. \n"
+ "Område 1a: S/10-20 knop, efterhand SO/15-20 knop, byar upp till 30 \n"
+ "knop. \n"
+ "Område 2c,3d: SO/10-15 knop. \n"
+ "Område 1b: S/15-20 knop, byar upp till 30 knop, efterhand SO/15-20 \n"
+ "knop, byar upp till 30 knop. \n"
+ "Område 2a,2b,3a,3b,3c: SO/5-10 knop, efterhand SO/10-15 knop. ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}