#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!\bwhole\b)((?:_|\b)whole(?:_|\b))"
Local $sString = "whole_anything" & @CRLF & _
"anything_whole" & @CRLF & _
"anything_whole_anything" & @CRLF & _
"anythingwholeanything" & @CRLF & _
"whole" & @CRLF & _
"whole_" & @CRLF & _
"_whole" & @CRLF & _
"_whole_"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")