re = /(?!\bwhole\b)((?:_|\b)whole(?:_|\b))/m
str = 'whole_anything
anything_whole
anything_whole_anything
anythingwholeanything
whole
whole_
_whole
_whole_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end