import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\bwhole\\b)((?:_|\\b)whole(?:_|\\b))";
final String string = "whole_anything\n"
+ "anything_whole\n"
+ "anything_whole_anything\n"
+ "anythingwholeanything\n"
+ "whole\n"
+ "whole_\n"
+ "_whole\n"
+ "_whole_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}