$re = '/(?!\bwhole\b)((?:_|\b)whole(?:_|\b))/m';
$str = 'whole_anything
anything_whole
anything_whole_anything
anythingwholeanything
whole
whole_
_whole
_whole_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);