import re
regex = re.compile(r"(?!\bwhole\b)((?:_|\b)whole(?:_|\b))", flags=re.MULTILINE)
test_str = ("whole_anything\n"
"anything_whole\n"
"anything_whole_anything\n"
"anythingwholeanything\n"
"whole\n"
"whole_\n"
"_whole\n"
"_whole_")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")