package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\s* input [^>]+ >`)
var str = `<!DOCTYPE html>
<html>
<head>
</head>
<body>
<form>
<label for="nome">Nome</label>
<input type="text" name="nome" id="nome"/><br><br>
<label for="email">email</label>
<input type="text" name="email" id="email"/><br><br>
<input type="submit" value="Enviar">
</form>
</body>
</html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}