// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)<\s* input [^>]+ >").unwrap();
let string = "<!DOCTYPE html>
<html>
<head>
</head>
<body>
<form>
<label for=\"nome\">Nome</label>
<input type=\"text\" name=\"nome\" id=\"nome\"/><br><br>
<label for=\"email\">email</label>
<input type=\"text\" name=\"email\" id=\"email\"/><br><br>
<input type=\"submit\" value=\"Enviar\">
</form>
</body>
</html>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}