re = /<\s* input [^>]+ >/x
str = '<!DOCTYPE html>
<html>
<head>
</head>
<body>
<form>
<label for="nome">Nome</label>
<input type="text" name="nome" id="nome"/><br><br>
<label for="email">email</label>
<input type="text" name="email" id="email"/><br><br>
<input type="submit" value="Enviar">
</form>
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end