$re = '/<\s* input [^>]+ >/x';
$str = '<!DOCTYPE html>
<html>
<head>
</head>
<body>
<form>
<label for="nome">Nome</label>
<input type="text" name="nome" id="nome"/><br><br>
<label for="email">email</label>
<input type="text" name="email" id="email"/><br><br>
<input type="submit" value="Enviar">
</form>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);