using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{2})(\d{2})";
string substitution = @"${1}0${2}";
string input = @"rdar://stc/86473072>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}