re = /^(\d{2})(\d{2})/
str = 'rdar://stc/86473072>'
subst = '${1}0${2}'
result = str.sub(re, subst)
# Print the result of the substitution
puts result