const regex = /^(\d{2})(\d{2})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{2})(\\d{2})', '')
const str = `rdar://stc/86473072>`;
const subst = `${1}0${2}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);