import Foundation
let pattern = #"^(\d{2})(\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"rdar://stc/86473072>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${1}0${2}"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}