#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\S+)(\s+IN\s+\(.*?),?\s*'null'(.*?\))"
Local $sString = "id == 123 and status IN ('Active','null')" & @CRLF & _
"id == 123 and status IN ('Active','test1','null')" & @CRLF & _
"id == 123 and status IN ('Active','test1','null',test2)" & @CRLF & _
"id == 123 and status IN ('null')"
Local $sSubst = "$1$2$3 or $1 is null"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)