using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+)(\s+IN\s+\(.*?),?\s*'null'(.*?\))";
string substitution = @"$1$2$3 or $1 is null";
string input = @"id == 123 and status IN ('Active','null')
id == 123 and status IN ('Active','test1','null')
id == 123 and status IN ('Active','test1','null',test2)
id == 123 and status IN ('null')";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}