import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S+)(\\s+IN\\s+\\(.*?),?\\s*'null'(.*?\\))";
final String string = "id == 123 and status IN ('Active','null')\n"
+ "id == 123 and status IN ('Active','test1','null')\n"
+ "id == 123 and status IN ('Active','test1','null',test2)\n"
+ "id == 123 and status IN ('null')";
final String subst = "$1$2$3 or $1 is null";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}