$re = '/(\S+)(\s+IN\s+\(.*?),?\s*\'null\'(.*?\))/';
$str = 'id == 123 and status IN (\'Active\',\'null\')
id == 123 and status IN (\'Active\',\'test1\',\'null\')
id == 123 and status IN (\'Active\',\'test1\',\'null\',test2)
id == 123 and status IN (\'null\')';
$subst = "$1$2$3 or $1 is null";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;