// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\S+)(\s+IN\s+\(.*?),?\s*'null'(.*?\))").unwrap();
let string = "id == 123 and status IN ('Active','null')
id == 123 and status IN ('Active','test1','null')
id == 123 and status IN ('Active','test1','null',test2)
id == 123 and status IN ('null')";
let substitution = "$1$2$3 or $1 is null";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}