re = /(\S+)(\s+IN\s+\(.*?),?\s*'null'(.*?\))/
str = 'id == 123 and status IN (\'Active\',\'null\')
id == 123 and status IN (\'Active\',\'test1\',\'null\')
id == 123 and status IN (\'Active\',\'test1\',\'null\',test2)
id == 123 and status IN (\'null\')'
subst = '$1$2$3 or $1 is null'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result