package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0?\d|[1][0-2])\/(0?[1-9]|[0-2]\d|[3][0-1])\/(\d{2})(?:(?:\s(0?[1-9]|1[012])\:([0-5]\d)(?:\s(AM|PM))?)?)$`)
var str = `12/31/00
5/5/14 12:04
05/05/24 5:54 AM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}