const regex = /^(0?\d|[1][0-2])\/(0?[1-9]|[0-2]\d|[3][0-1])\/(\d{2})(?:(?:\s(0?[1-9]|1[012])\:([0-5]\d)(?:\s(AM|PM))?)?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0?\\d|[1][0-2])\\\/(0?[1-9]|[0-2]\\d|[3][0-1])\\\/(\\d{2})(?:(?:\\s(0?[1-9]|1[012])\\:([0-5]\\d)(?:\\s(AM|PM))?)?)$', 'gm')
const str = `12/31/00
5/5/14 12:04
05/05/24 5:54 AM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}