use strict;
my $str = '12/31/00
5/5/14 12:04
05/05/24 5:54 AM';
my $regex = qr/^(0?\d|[1][0-2])\/(0?[1-9]|[0-2]\d|[3][0-1])\/(\d{2})(?:(?:\s(0?[1-9]|1[012])\:([0-5]\d)(?:\s(AM|PM))?)?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}