#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-\d{4}-\d{2}-\d{2}.*$"
Local $sString = "GN1RLWFH0546-2020-04-10-18-09-52-563945.txt" & @CRLF & _
"JOHN-DOE-2020-04-10-18-09-52-563946t64.txt" & @CRLF & _
"DESKTOP-OHK45JO-2020-04-09-02-27-11-451975.txt"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)