$re = '/-\d{4}-\d{2}-\d{2}.*$/m';
$str = 'GN1RLWFH0546-2020-04-10-18-09-52-563945.txt
JOHN-DOE-2020-04-10-18-09-52-563946t64.txt
DESKTOP-OHK45JO-2020-04-09-02-27-11-451975.txt';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;