const regex = /-\d{4}-\d{2}-\d{2}.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\d{4}-\\d{2}-\\d{2}.*$', 'gm')
const str = `GN1RLWFH0546-2020-04-10-18-09-52-563945.txt
JOHN-DOE-2020-04-10-18-09-52-563946t64.txt
DESKTOP-OHK45JO-2020-04-09-02-27-11-451975.txt`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);