import re
regex = re.compile(r"-\d{4}-\d{2}-\d{2}.*$", flags=re.MULTILINE)
test_str = ("GN1RLWFH0546-2020-04-10-18-09-52-563945.txt\n"
"JOHN-DOE-2020-04-10-18-09-52-563946t64.txt\n"
"DESKTOP-OHK45JO-2020-04-09-02-27-11-451975.txt")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)