#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(Q)(\d)"
Local $sString = "Q7" & @CRLF & _
"Q2"
Local $sSubst = "$2 Queen"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)