$re = '/(Q)(\d)/i';
$str = 'Q7
Q2';
$subst = "$2 Queen";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;