const regex = /(Q)(\d)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Q)(\\d)', 'gi')
const str = `Q7
Q2`;
const subst = `$2 Queen`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);