package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(Q)(\d)`)
var str = `Q7
Q2`
var substitution = "$2 Queen"
fmt.Println(re.ReplaceAllString(str, substitution))
}