// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(Q)(\d)").unwrap();
let string = "Q7
Q2";
let substitution = "$2 Queen";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}