use strict;
my $str = 'Q7
Q2';
my $regex = qr/(Q)(\d)/ip;
my $subst = '$2 Queen';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";