using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^""](?={{)(.*?)}}[^""]";
string substitution = @"sads";
string input = @"Nemo enim ipsam voluptatem quia {{ voluptas }} labore et {{ dolore }} eum
<a href="" {{iure}}abc "" dasdas>{{reprehenderit}}<dsa /a> qui <a href=""{{ news }}"">{{smart}}</a> ea.""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}