re = /[^"](?={{)(.*?)}}[^"]/
str = 'Nemo enim ipsam voluptatem quia {{ voluptas }} labore et {{ dolore }} eum
<a href=" {{iure}}abc " dasdas>{{reprehenderit}}<dsa /a> qui <a href="{{ news }}">{{smart}}</a> ea."
'
subst = 'sads'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result