const regex = /[^"](?={{)(.*?)}}[^"]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^"](?={{)(.*?)}}[^"]', 'g')
const str = `Nemo enim ipsam voluptatem quia {{ voluptas }} labore et {{ dolore }} eum
<a href=" {{iure}}abc " dasdas>{{reprehenderit}}<dsa /a> qui <a href="{{ news }}">{{smart}}</a> ea."
`;
const subst = `sads`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);