import Foundation
let pattern = #"[^"](?={{)(.*?)}}[^"]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Nemo enim ipsam voluptatem quia {{ voluptas }} labore et {{ dolore }} eum
<a href=" {{iure}}abc " dasdas>{{reprehenderit}}<dsa /a> qui <a href="{{ news }}">{{smart}}</a> ea."
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"sads"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)