#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\bsome_name\b)(.|\s)*?(\bEND\b)"
Local $sString = "NAME: some_name" & @CRLF & _
" UNIT: some_unit" & @CRLF & _
" VALUE: 10" & @CRLF & _
"END" & @CRLF & _
"" & @CRLF & _
"NAME: some_name2" & @CRLF & _
" UNIT: some_unit" & @CRLF & _
" VALUE: 10" & @CRLF & _
"END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")