// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\bsome_name\b)(.|\s)*?(\bEND\b)").unwrap();
let string = "NAME: some_name
UNIT: some_unit
VALUE: 10
END
NAME: some_name2
UNIT: some_unit
VALUE: 10
END";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}