const regex = new RegExp('(\\bsome_name\\b)(.|\\s)*?(\\bEND\\b)', 'gm')
const str = `NAME: some_name
UNIT: some_unit
VALUE: 10
END
NAME: some_name2
UNIT: some_unit
VALUE: 10
END`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}