package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\bsome_name\b)(.|\s)*?(\bEND\b)`)
var str = `NAME: some_name
UNIT: some_unit
VALUE: 10
END
NAME: some_name2
UNIT: some_unit
VALUE: 10
END`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}