import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bsome_name\\b)(.|\\s)*?(\\bEND\\b)";
final String string = "NAME: some_name\n"
+ " UNIT: some_unit\n"
+ " VALUE: 10\n"
+ "END\n\n"
+ "NAME: some_name2\n"
+ " UNIT: some_unit\n"
+ " VALUE: 10\n"
+ "END";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}