using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bsome_name\b)(.|\s)*?(\bEND\b)";
string input = @"NAME: some_name
UNIT: some_unit
VALUE: 10
END
NAME: some_name2
UNIT: some_unit
VALUE: 10
END";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}