using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"->(\d+)";
string substitution = @"[\1]";
string input = @"channel->0->item->0->guid->0";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}